WindowsServer2003にPostgresをインストールする

WindowsServer2003にPostgresをインストールする

とりあえず最新版はインストールできません。

結論ですが、「9.3」であればインストール可能です。
※ランタイムのバージョンが合わないっぽいです。

ただし、AdminⅢを新しいPostgresに接続するとDLLが足りない旨の
エラーが表示されます。

AdminⅢからではなくコマンドプロンプトからであれば操作可能です。
※もしくはA5MK2でも大丈夫です。

インストール時、以下のオプションで実行してください。
※「an error occured executing the microsoft vc++ runtime installer」」の回避

–install_runtimes 0

参考サイトは以下となります。
※役に立った順に

Can’t install PostgreSQL: An error occurred executing the Microsoft VC++ runtime installer on Windows XP
PostgreSQLインストールエラー(Win)
PostgreSQLインストール時のエラー

postgreカテゴリの最新記事